Important Security Information - Action Required
 

If you're seeing this page, it means your browser settings aren't compatible with the enhanced security requirements we implemented to better safeguard your information. Below you will find a document containing simple instructions to enable these settings. If you aren't comfortable changing your browser's settings, please contact your organization's technical support personnel and show them these instructions. 

Unfortunately due to operating system limitations, Windows XP and Windows Vista will not support TLS 1.1 and TLS 1.2 in Internet Explorer. Only Windows 7 or later operating systems support these protocols.

Thank you for your patience and understanding as we strive to protect all of the data that is so critical to our members!

Download the PDF instructions


 
  My Account
  MY KLCIS TEAM
  CLAIMS
  POLICIES
  SCORE CARD
  REPORTS